$re = '~//([\w-]+\.)+(\w+).*~m';
$str = 'https://site.ru
http://assembly.site.com
http://civil-law.site.ru/wist/vved.html
https://ru.site.net/wiki/О_культе_личности_и_его_последствиях._Доклад_XX_съезду_КПСС_(Н.С._Хрущёв)';
$subst = "//$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;