#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)//([\w-]+\.)+(\w+).*"
Local $sString = "https://site.ru" & @CRLF & _
"http://assembly.site.com" & @CRLF & _
"http://civil-law.site.ru/wist/vved.html" & @CRLF & _
"https://ru.site.net/wiki/О_культе_личности_и_его_последствиях._Доклад_XX_съезду_КПСС_(Н.С._Хрущёв)"
Local $sSubst = "//$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)