using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"//([\w-]+\.)+(\w+).*";
string substitution = @"//$1$2";
string input = @"https://site.ru
http://assembly.site.com
http://civil-law.site.ru/wist/vved.html
https://ru.site.net/wiki/О_культе_личности_и_его_последствиях._Доклад_XX_съезду_КПСС_(Н.С._Хрущёв)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}