use strict;
my $str = 'https://site.ru
http://assembly.site.com
http://civil-law.site.ru/wist/vved.html
https://ru.site.net/wiki/О_культе_личности_и_его_последствиях._Доклад_XX_съезду_КПСС_(Н.С._Хрущёв)';
my $regex = qr~//([\w-]+\.)+(\w+).*~mp;
my $subst = '//$1$2';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";