#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*\.h\.scss$).*\.scss$"
Local $sString = "*.h.scss" & @CRLF & _
"*.scss" & @CRLF & _
"*.h1.scss" & @CRLF & _
"" & @CRLF & _
"I need a regular expression that match *.scss file name, but didn't match the names like *.h.scss. "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")