import re
regex = re.compile(r"^(?!.*\.h\.scss$).*\.scss$", flags=re.MULTILINE)
test_str = ("*.h.scss\n"
"*.scss\n"
"*.h1.scss\n\n"
"I need a regular expression that match *.scss file name, but didn't match the names like *.h.scss. ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")