re = /^(?!.*\.h\.scss$).*\.scss$/m
str = '*.h.scss
*.scss
*.h1.scss
I need a regular expression that match *.scss file name, but didn\'t match the names like *.h.scss. '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end