using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*\.h\.scss$).*\.scss$";
string input = @"*.h.scss
*.scss
*.h1.scss
I need a regular expression that match *.scss file name, but didn't match the names like *.h.scss. ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}