import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*\\.h\\.scss$).*\\.scss$";
final String string = "*.h.scss\n"
+ "*.scss\n"
+ "*.h1.scss\n\n"
+ "I need a regular expression that match *.scss file name, but didn't match the names like *.h.scss. ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}