const regex = /^(?!.*\.h\.scss$).*\.scss$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*\\.h\\.scss$).*\\.scss$', 'mg')
const str = `*.h.scss
*.scss
*.h1.scss
I need a regular expression that match *.scss file name, but didn't match the names like *.h.scss. `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}