using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^http://127\.0\.0\.1:5000/countries(?:\?\w+=[\s\w]+(?:&\w+=[\s\w]+)*)?$";
string input = @"http://127.0.0.1:5000/x
http://127.0.0.1:5000/countries?
http://127.0.0.1:5000/countries?x
http://127.0.0.1:5000/countries?=
http://127.0.0.1:5000/countries?x=
http://127.0.0.1:5000/countries&
http://127.0.0.1:5000/countries&x
http://127.0.0.1:5000/countries&=
http://127.0.0.1:5000/countries&x=
http://127.0.0.1:5000/countries&x=x
http://127.0.0.1:5000/countries?code=AU?
http://127.0.0.1:5000/countries?name=Australia?x
http://127.0.0.1:5000/countries?name=Australia?=
http://127.0.0.1:5000/countries?name=Australia?x=
http://127.0.0.1:5000/countries?name=Australia?x=x
http://127.0.0.1:5000/countries?name=Australia&
http://127.0.0.1:5000/countries?name=Australia&x
http://127.0.0.1:5000/countries?name=Australia&=
http://127.0.0.1:5000/countries?name=Australia&x=
http://127.0.0.1:5000/countries
http://127.0.0.1:5000/countries?name=Australia
http://127.0.0.1:5000/countries?code=AU&name=Australia
http://127.0.0.1:5000/countries?name=New Zealand&calling_code=64
http://127.0.0.1:5000/countries?code=AU&name=Australia&capital=Canberra";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}