$re = '/^http://127\.0\.0\.1:5000/countries(?:\?\w+=[\s\w]+(?:&\w+=[\s\w]+)*)?$/m';
$str = 'http://127.0.0.1:5000/x
http://127.0.0.1:5000/countries?
http://127.0.0.1:5000/countries?x
http://127.0.0.1:5000/countries?=
http://127.0.0.1:5000/countries?x=
http://127.0.0.1:5000/countries&
http://127.0.0.1:5000/countries&x
http://127.0.0.1:5000/countries&=
http://127.0.0.1:5000/countries&x=
http://127.0.0.1:5000/countries&x=x
http://127.0.0.1:5000/countries?code=AU?
http://127.0.0.1:5000/countries?name=Australia?x
http://127.0.0.1:5000/countries?name=Australia?=
http://127.0.0.1:5000/countries?name=Australia?x=
http://127.0.0.1:5000/countries?name=Australia?x=x
http://127.0.0.1:5000/countries?name=Australia&
http://127.0.0.1:5000/countries?name=Australia&x
http://127.0.0.1:5000/countries?name=Australia&=
http://127.0.0.1:5000/countries?name=Australia&x=
http://127.0.0.1:5000/countries
http://127.0.0.1:5000/countries?name=Australia
http://127.0.0.1:5000/countries?code=AU&name=Australia
http://127.0.0.1:5000/countries?name=New Zealand&calling_code=64
http://127.0.0.1:5000/countries?code=AU&name=Australia&capital=Canberra';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);