import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^http://127\\.0\\.0\\.1:5000/countries(?:\\?\\w+=[\\s\\w]+(?:&\\w+=[\\s\\w]+)*)?$";
final String string = "http://127.0.0.1:5000/x\n"
+ "http://127.0.0.1:5000/countries?\n"
+ "http://127.0.0.1:5000/countries?x\n"
+ "http://127.0.0.1:5000/countries?=\n"
+ "http://127.0.0.1:5000/countries?x=\n"
+ "http://127.0.0.1:5000/countries&\n"
+ "http://127.0.0.1:5000/countries&x\n"
+ "http://127.0.0.1:5000/countries&=\n"
+ "http://127.0.0.1:5000/countries&x=\n"
+ "http://127.0.0.1:5000/countries&x=x\n"
+ "http://127.0.0.1:5000/countries?code=AU?\n"
+ "http://127.0.0.1:5000/countries?name=Australia?x\n"
+ "http://127.0.0.1:5000/countries?name=Australia?=\n"
+ "http://127.0.0.1:5000/countries?name=Australia?x=\n"
+ "http://127.0.0.1:5000/countries?name=Australia?x=x\n"
+ "http://127.0.0.1:5000/countries?name=Australia&\n"
+ "http://127.0.0.1:5000/countries?name=Australia&x\n"
+ "http://127.0.0.1:5000/countries?name=Australia&=\n"
+ "http://127.0.0.1:5000/countries?name=Australia&x=\n"
+ "http://127.0.0.1:5000/countries\n"
+ "http://127.0.0.1:5000/countries?name=Australia\n"
+ "http://127.0.0.1:5000/countries?code=AU&name=Australia\n"
+ "http://127.0.0.1:5000/countries?name=New Zealand&calling_code=64\n"
+ "http://127.0.0.1:5000/countries?code=AU&name=Australia&capital=Canberra";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}