import re
regex = re.compile(r"^http://127\.0\.0\.1:5000/countries(?:\?\w+=[\s\w]+(?:&\w+=[\s\w]+)*)?$", flags=re.MULTILINE)
test_str = ("http://127.0.0.1:5000/x\n"
"http://127.0.0.1:5000/countries?\n"
"http://127.0.0.1:5000/countries?x\n"
"http://127.0.0.1:5000/countries?=\n"
"http://127.0.0.1:5000/countries?x=\n"
"http://127.0.0.1:5000/countries&\n"
"http://127.0.0.1:5000/countries&x\n"
"http://127.0.0.1:5000/countries&=\n"
"http://127.0.0.1:5000/countries&x=\n"
"http://127.0.0.1:5000/countries&x=x\n"
"http://127.0.0.1:5000/countries?code=AU?\n"
"http://127.0.0.1:5000/countries?name=Australia?x\n"
"http://127.0.0.1:5000/countries?name=Australia?=\n"
"http://127.0.0.1:5000/countries?name=Australia?x=\n"
"http://127.0.0.1:5000/countries?name=Australia?x=x\n"
"http://127.0.0.1:5000/countries?name=Australia&\n"
"http://127.0.0.1:5000/countries?name=Australia&x\n"
"http://127.0.0.1:5000/countries?name=Australia&=\n"
"http://127.0.0.1:5000/countries?name=Australia&x=\n"
"http://127.0.0.1:5000/countries\n"
"http://127.0.0.1:5000/countries?name=Australia\n"
"http://127.0.0.1:5000/countries?code=AU&name=Australia\n"
"http://127.0.0.1:5000/countries?name=New Zealand&calling_code=64\n"
"http://127.0.0.1:5000/countries?code=AU&name=Australia&capital=Canberra")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")