#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d{16})|(\d{4}\s\d{4}\s\d{4}\s\d{4})|(\d{4}\-?\d{4}\-?\d{4}\-?\d{4})"
Local $sString = "4943517653713763" & @CRLF & _
"4552 0518 0032 8285" & @CRLF & _
"4784-4511-1142-3090"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")