// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d{16})|(\d{4}\s\d{4}\s\d{4}\s\d{4})|(\d{4}\-?\d{4}\-?\d{4}\-?\d{4})").unwrap();
let string = "4943517653713763
4552 0518 0032 8285
4784-4511-1142-3090";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}