import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{16})|(\\d{4}\\s\\d{4}\\s\\d{4}\\s\\d{4})|(\\d{4}\\-?\\d{4}\\-?\\d{4}\\-?\\d{4})";
final String string = "4943517653713763\n"
+ "4552 0518 0032 8285\n"
+ "4784-4511-1142-3090";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}