import re
regex = re.compile(r"(\d{16})|(\d{4}\s\d{4}\s\d{4}\s\d{4})|(\d{4}\-?\d{4}\-?\d{4}\-?\d{4})")
test_str = ("4943517653713763\n"
"4552 0518 0032 8285\n"
"4784-4511-1142-3090")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")