package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{16})|(\d{4}\s\d{4}\s\d{4}\s\d{4})|(\d{4}\-?\d{4}\-?\d{4}\-?\d{4})`)
var str = `4943517653713763
4552 0518 0032 8285
4784-4511-1142-3090`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}