re = /(\d{16})|(\d{4}\s\d{4}\s\d{4}\s\d{4})|(\d{4}\-?\d{4}\-?\d{4}\-?\d{4})/
str = '4943517653713763
4552 0518 0032 8285
4784-4511-1142-3090'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end