const regex = /(\d{16})|(\d{4}\s\d{4}\s\d{4}\s\d{4})|(\d{4}\-?\d{4}\-?\d{4}\-?\d{4})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{16})|(\\d{4}\\s\\d{4}\\s\\d{4}\\s\\d{4})|(\\d{4}\\-?\\d{4}\\-?\\d{4}\\-?\\d{4})', 'g')
const str = `4943517653713763
4552 0518 0032 8285
4784-4511-1142-3090`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}