using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<![\s\S\r])(---\ntitle:\s)([1-9a-zA-ZÀ-ŰØ-űø-ÿ].*)([\d\D]*---\n\n#\s[1-9a-zA-ZÀ-ŰØ-űø-ÿ].*)";
string substitution = @"$1$2$3\n\n%%\n```query\nfile: ""$2.md"" /\\[\\[(?!.*\\|)([^[\\]]+#[^\\]]+)\\]\\]/\n```\n%%";
string input = @"---
title: Title can be anything
aliases:
- somealias
tags:
- sometag
topic: sometopic
anotheryamlKey: whatever
date created: 2022-12-14
date modified: 2023-10-06
---
# Title can be anything
First line of file.
Second line. ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}