re = /^(?<![\s\S\r])(---\ntitle:\s)([1-9a-zA-ZÀ-ŰØ-űø-ÿ].*)([\d\D]*---\n\n#\s[1-9a-zA-ZÀ-ŰØ-űø-ÿ].*)/m
str = '---
title: Title can be anything
aliases:
- somealias
tags:
- sometag
topic: sometopic
anotheryamlKey: whatever
date created: 2022-12-14
date modified: 2023-10-06
---
# Title can be anything
First line of file.
Second line. '
subst = '$1$2$3\\n\\n%%\\n```query\\nfile: "$2.md" /\\\\[\\\\[(?!.*\\\\|)([^[\\\\]]+#[^\\\\]]+)\\\\]\\\\]/\\n```\\n%%'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result