import Foundation
let pattern = ##"^(?<![\s\S\r])(---\ntitle:\s)([1-9a-zA-ZÀ-ŰØ-űø-ÿ].*)([\d\D]*---\n\n#\s[1-9a-zA-ZÀ-ŰØ-űø-ÿ].*)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
---
title: Title can be anything
aliases:
- somealias
tags:
- sometag
topic: sometopic
anotheryamlKey: whatever
date created: 2022-12-14
date modified: 2023-10-06
---
# Title can be anything
First line of file.
Second line.
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"$1$2$3\n\n%%\n```query\nfile: "$2.md" /\\[\\[(?!.*\\|)([^[\\]]+#[^\\]]+)\\]\\]/\n```\n%%"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)