use strict;
my $str = '---
title: Title can be anything
aliases:
- somealias
tags:
- sometag
topic: sometopic
anotheryamlKey: whatever
date created: 2022-12-14
date modified: 2023-10-06
---
# Title can be anything
First line of file.
Second line. ';
my $regex = qr/^(?<![\s\S\r])(---\ntitle:\s)([1-9a-zA-ZÀ-ŰØ-űø-ÿ].*)([\d\D]*---\n\n#\s[1-9a-zA-ZÀ-ŰØ-űø-ÿ].*)/mp;
my $subst = '$1$2$3\\n\\n%%\\n```query\\nfile: "$2.md" /\\\\[\\\\[(?!.*\\\\|)([^[\\\\]]+#[^\\\\]]+)\\\\]\\\\]/\\n```\\n%%';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";