import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<![\\s\\S\\r])(---\\ntitle:\\s)([1-9a-zA-ZÀ-ŰØ-űø-ÿ].*)([\\d\\D]*---\\n\\n#\\s[1-9a-zA-ZÀ-ŰØ-űø-ÿ].*)";
final String string = "---\n"
+ "title: Title can be anything\n"
+ "aliases:\n"
+ " - somealias\n"
+ "tags:\n"
+ " - sometag\n"
+ "topic: sometopic\n"
+ "anotheryamlKey: whatever\n"
+ "date created: 2022-12-14\n"
+ "date modified: 2023-10-06\n"
+ "---\n\n"
+ "# Title can be anything\n\n"
+ "First line of file. \n"
+ "Second line. ";
final String subst = "$1$2$3\\n\\n%%\\n```query\\nfile: \"$2.md\" /\\\\[\\\\[(?!.*\\\\|)([^[\\\\]]+#[^\\\\]]+)\\\\]\\\\]/\\n```\\n%%";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}