#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Za-z](\d|[A-Za-z]|_){2,29}$"
Local $sString = "Mahgul(Already Existing)" & @CRLF & _
"Mahgul/MAHGUL" & @CRLF & _
"mahgul123_" & @CRLF & _
"space bar" & @CRLF & _
"â—™asda" & @CRLF & _
"MahgulhussainAhmedyousufzai123" & @CRLF & _
"MahgulhussainAhmedyousufzai1234567890" & @CRLF & _
"asdasd" & @CRLF & _
"_123asd" & @CRLF & _
"123asd_" & @CRLF & _
"asd123_" & @CRLF & _
"asd_123" & @CRLF & _
"asd.123" & @CRLF & _
"AAAAAAA" & @CRLF & _
"ali_123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")