package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z](\d|[A-Za-z]|_){2,29}$`)
var str = `Mahgul(Already Existing)
Mahgul/MAHGUL
mahgul123_
space bar
â—™asda
MahgulhussainAhmedyousufzai123
MahgulhussainAhmedyousufzai1234567890
asdasd
_123asd
123asd_
asd123_
asd_123
asd.123
AAAAAAA
ali_123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}