import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Za-z](\\d|[A-Za-z]|_){2,29}$";
final String string = "Mahgul(Already Existing)\n"
+ "Mahgul/MAHGUL\n"
+ "mahgul123_\n"
+ "space bar\n"
+ "â—™asda\n"
+ "MahgulhussainAhmedyousufzai123\n"
+ "MahgulhussainAhmedyousufzai1234567890\n"
+ "asdasd\n"
+ "_123asd\n"
+ "123asd_\n"
+ "asd123_\n"
+ "asd_123\n"
+ "asd.123\n"
+ "AAAAAAA\n"
+ "ali_123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}