use strict;
my $str = 'Mahgul(Already Existing)
Mahgul/MAHGUL
mahgul123_
space bar
â—™asda
MahgulhussainAhmedyousufzai123
MahgulhussainAhmedyousufzai1234567890
asdasd
_123asd
123asd_
asd123_
asd_123
asd.123
AAAAAAA
ali_123';
my $regex = qr/^[A-Za-z](\d|[A-Za-z]|_){2,29}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}