$re = '/^[A-Za-z](\d|[A-Za-z]|_){2,29}$/m';
$str = 'Mahgul(Already Existing)
Mahgul/MAHGUL
mahgul123_
space bar
â—™asda
MahgulhussainAhmedyousufzai123
MahgulhussainAhmedyousufzai1234567890
asdasd
_123asd
123asd_
asd123_
asd_123
asd.123
AAAAAAA
ali_123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);