import Foundation
let pattern = #"^[A-Za-z](\d|[A-Za-z]|_){2,29}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Mahgul(Already Existing)
Mahgul/MAHGUL
mahgul123_
space bar
â—™asda
MahgulhussainAhmedyousufzai123
MahgulhussainAhmedyousufzai1234567890
asdasd
_123asd
123asd_
asd123_
asd_123
asd.123
AAAAAAA
ali_123
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)