import re
regex = re.compile(r"^[A-Za-z](\d|[A-Za-z]|_){2,29}$", flags=re.MULTILINE)
test_str = ("Mahgul(Already Existing)\n"
"Mahgul/MAHGUL\n"
"mahgul123_\n"
"space bar\n"
"â—™asda\n"
"MahgulhussainAhmedyousufzai123\n"
"MahgulhussainAhmedyousufzai1234567890\n"
"asdasd\n"
"_123asd\n"
"123asd_\n"
"asd123_\n"
"asd_123\n"
"asd.123\n"
"AAAAAAA\n"
"ali_123")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")