$re = '/(?:[^!]\[(?P<caption>.*?)\])\((?P<image>.*?)\)/m';
$str = 'This is a regex to detect markdown image links of the form 
{#fig:id}
{#fig:id tag="B.1"}
{#fig:ch0_1_images-1 width=100%}





















';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);