import re
regex = re.compile(r"(?:[^!]\[(?P<caption>.*?)\])\((?P<image>.*?)\)", flags=re.MULTILINE)
test_str = ("This is a regex to detect markdown image links of the form \n\n"
"{#fig:id}\n"
"{#fig:id tag=\"B.1\"}\n"
"{#fig:ch0_1_images-1 width=100%}\n"
"\n"
"\n"
"\n"
"\n"
"\n"
"\n"
"\n"
"\n"
"\n"
"\n"
"\n"
"\n"
"\n"
"\n"
"\n"
"\n"
"\n"
"\n"
"\n"
"\n"
"\n"
"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")