#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*((?:\s*[-]?(?:\s*\d)+(?:\s*[.](?:\s*\d)+)?\s*,){6}\s*[10]\s*,\s*[-]?(?:\s*\d)+?(?:\s*[.](?:\s*\d)+?)?)$"
Local $sString = "26.9841,300.007666,4,1,0,15,1,0" & @CRLF & _
"" & @CRLF & _
"26 . 9841,300 . 007666,4,1,0,15,1,0" & @CRLF & _
"" & @CRLF & _
"26.9841" & @CRLF & _
",300.007666" & @CRLF & _
",4," & @CRLF & _
"1,0,15,1,0" & @CRLF & _
"" & @CRLF & _
"2 6 . 9 8 4 1 ," & @CRLF & _
" 3 0 0 .0 0 7 6 6 6 , 4 " & @CRLF & _
", 1 , 0 , 1 5 , 1 , 0" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")