// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s*((?:\s*[-]?(?:\s*\d)+(?:\s*[.](?:\s*\d)+)?\s*,){6}\s*[10]\s*,\s*[-]?(?:\s*\d)+?(?:\s*[.](?:\s*\d)+?)?)$").unwrap();
let string = "26.9841,300.007666,4,1,0,15,1,0
26 . 9841,300 . 007666,4,1,0,15,1,0
26.9841
,300.007666
,4,
1,0,15,1,0
2 6 . 9 8 4 1 ,
3 0 0 .0 0 7 6 6 6 , 4
, 1 , 0 , 1 5 , 1 , 0
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}