import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*((?:\\s*[-]?(?:\\s*\\d)+(?:\\s*[.](?:\\s*\\d)+)?\\s*,){6}\\s*[10]\\s*,\\s*[-]?(?:\\s*\\d)+?(?:\\s*[.](?:\\s*\\d)+?)?)$";
final String string = "26.9841,300.007666,4,1,0,15,1,0\n\n"
+ "26 . 9841,300 . 007666,4,1,0,15,1,0\n\n"
+ "26.9841\n"
+ ",300.007666\n"
+ ",4,\n"
+ "1,0,15,1,0\n\n"
+ "2 6 . 9 8 4 1 ,\n"
+ " 3 0 0 .0 0 7 6 6 6 , 4 \n"
+ ", 1 , 0 , 1 5 , 1 , 0\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}