use strict;
my $str = '26.9841,300.007666,4,1,0,15,1,0
26 . 9841,300 . 007666,4,1,0,15,1,0
26.9841
,300.007666
,4,
1,0,15,1,0
2 6 . 9 8 4 1 ,
3 0 0 .0 0 7 6 6 6 , 4
, 1 , 0 , 1 5 , 1 , 0
';
my $regex = qr/^\s*((?:\s*[-]?(?:\s*\d)+(?:\s*[.](?:\s*\d)+)?\s*,){6}\s*[10]\s*,\s*[-]?(?:\s*\d)+?(?:\s*[.](?:\s*\d)+?)?)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}