import re
regex = re.compile(r"^\s*((?:\s*[-]?(?:\s*\d)+(?:\s*[.](?:\s*\d)+)?\s*,){6}\s*[10]\s*,\s*[-]?(?:\s*\d)+?(?:\s*[.](?:\s*\d)+?)?)$", flags=re.MULTILINE)
test_str = ("26.9841,300.007666,4,1,0,15,1,0\n\n"
"26 . 9841,300 . 007666,4,1,0,15,1,0\n\n"
"26.9841\n"
",300.007666\n"
",4,\n"
"1,0,15,1,0\n\n"
"2 6 . 9 8 4 1 ,\n"
" 3 0 0 .0 0 7 6 6 6 , 4 \n"
", 1 , 0 , 1 5 , 1 , 0\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")