const regex = new RegExp('^\\s*((?:\\s*[-]?(?:\\s*\\d)+(?:\\s*[.](?:\\s*\\d)+)?\\s*,){6}\\s*[10]\\s*,\\s*[-]?(?:\\s*\\d)+?(?:\\s*[.](?:\\s*\\d)+?)?)$', 'gm')
const str = `26.9841,300.007666,4,1,0,15,1,0
26 . 9841,300 . 007666,4,1,0,15,1,0
26.9841
,300.007666
,4,
1,0,15,1,0
2 6 . 9 8 4 1 ,
3 0 0 .0 0 7 6 6 6 , 4
, 1 , 0 , 1 5 , 1 , 0
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}