re = /^\s*((?:\s*[-]?(?:\s*\d)+(?:\s*[.](?:\s*\d)+)?\s*,){6}\s*[10]\s*,\s*[-]?(?:\s*\d)+?(?:\s*[.](?:\s*\d)+?)?)$/m
str = '26.9841,300.007666,4,1,0,15,1,0
26 . 9841,300 . 007666,4,1,0,15,1,0
26.9841
,300.007666
,4,
1,0,15,1,0
2 6 . 9 8 4 1 ,
3 0 0 .0 0 7 6 6 6 , 4
, 1 , 0 , 1 5 , 1 , 0
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end