#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:(?<= )C(?=[ \d#])|\bCR(?=\d*))"
Local $sString = "LA NAVARRA" & @CRLF & _
"" & @CRLF & _
"BARRIO VILLANUEVA CR 40 # 01-02" & @CRLF & _
"" & @CRLF & _
"CR 32 # 92-00" & @CRLF & _
"" & @CRLF & _
"SIN DATO LA NOMENCLATURA" & @CRLF & _
"" & @CRLF & _
"CR4#89-00" & @CRLF & _
"" & @CRLF & _
"TESTCRTEST" & @CRLF & _
"" & @CRLF & _
"AV : LA NAVARRA CL : SIN DATO LA NOMENCLATURA" & @CRLF & _
"" & @CRLF & _
"Test C test" & @CRLF & _
"Test C#4 test" & @CRLF & _
" C " & @CRLF & _
" C5 " & @CRLF & _
" C#6" & @CRLF & _
" C#" & @CRLF & _
"C " & @CRLF & _
"C^" & @CRLF & _
"WordthatendswithC" & @CRLF & _
"WordthatendswithCandwhitespace " & @CRLF & _
"test" & @CRLF & _
"C$%$$#%" & @CRLF & _
"C test C" & @CRLF & _
"C" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")