using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?<= )C(?=[ \d#])|\bCR(?=\d*))";
string input = @"LA NAVARRA
BARRIO VILLANUEVA CR 40 # 01-02
CR 32 # 92-00
SIN DATO LA NOMENCLATURA
CR4#89-00
TESTCRTEST
AV : LA NAVARRA CL : SIN DATO LA NOMENCLATURA
Test C test
Test C#4 test
C
C5
C#6
C#
C
C^
WordthatendswithC
WordthatendswithCandwhitespace
test
C$%$$#%
C test C
C
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}