$re = '/(?:(?<= )C(?=[ \d#])|\bCR(?=\d*))/';
$str = 'LA NAVARRA
BARRIO VILLANUEVA CR 40 # 01-02
CR 32 # 92-00
SIN DATO LA NOMENCLATURA
CR4#89-00
TESTCRTEST
AV : LA NAVARRA CL : SIN DATO LA NOMENCLATURA
Test C test
Test C#4 test
C
C5
C#6
C#
C
C^
WordthatendswithC
WordthatendswithCandwhitespace
test
C$%$$#%
C test C
C
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);