use strict;
my $str = 'LA NAVARRA
BARRIO VILLANUEVA CR 40 # 01-02
CR 32 # 92-00
SIN DATO LA NOMENCLATURA
CR4#89-00
TESTCRTEST
AV : LA NAVARRA CL : SIN DATO LA NOMENCLATURA
Test C test
Test C#4 test
C
C5
C#6
C#
C
C^
WordthatendswithC
WordthatendswithCandwhitespace
test
C$%$$#%
C test C
C
';
my $regex = qr/(?:(?<= )C(?=[ \d#])|\bCR(?=\d*))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}