# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(?<= )C(?=[ \d#])|\bCR(?=\d*))"
test_str = ("LA NAVARRA\n\n"
"BARRIO VILLANUEVA CR 40 # 01-02\n\n"
"CR 32 # 92-00\n\n"
"SIN DATO LA NOMENCLATURA\n\n"
"CR4#89-00\n\n"
"TESTCRTEST\n\n"
"AV : LA NAVARRA CL : SIN DATO LA NOMENCLATURA\n\n"
"Test C test\n"
"Test C#4 test\n"
" C \n"
" C5 \n"
" C#6\n"
" C#\n"
"C \n"
"C^\n"
"WordthatendswithC\n"
"WordthatendswithCandwhitespace \n"
"test\n"
"C$%$$#%\n"
"C test C\n"
"C\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.