import Foundation
let pattern = ##"(?:(?<= )C(?=[ \d#])|\bCR(?=\d*))"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
LA NAVARRA
BARRIO VILLANUEVA CR 40 # 01-02
CR 32 # 92-00
SIN DATO LA NOMENCLATURA
CR4#89-00
TESTCRTEST
AV : LA NAVARRA CL : SIN DATO LA NOMENCLATURA
Test C test
Test C#4 test
C
C5
C#6
C#
C
C^
WordthatendswithC
WordthatendswithCandwhitespace
test
C$%$$#%
C test C
C
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)