import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?<= )C(?=[ \\d#])|\\bCR(?=\\d*))";
final String string = "LA NAVARRA\n\n"
+ "BARRIO VILLANUEVA CR 40 # 01-02\n\n"
+ "CR 32 # 92-00\n\n"
+ "SIN DATO LA NOMENCLATURA\n\n"
+ "CR4#89-00\n\n"
+ "TESTCRTEST\n\n"
+ "AV : LA NAVARRA CL : SIN DATO LA NOMENCLATURA\n\n"
+ "Test C test\n"
+ "Test C#4 test\n"
+ " C \n"
+ " C5 \n"
+ " C#6\n"
+ " C#\n"
+ "C \n"
+ "C^\n"
+ "WordthatendswithC\n"
+ "WordthatendswithCandwhitespace \n"
+ "test\n"
+ "C$%$$#%\n"
+ "C test C\n"
+ "C\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}