#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)#000#000#000(?<call_date>[0-9]{6})\s{6}(?<call_time>[0-9]{4})(?<call_duration>[0-9]{4}).{9}(?<dialed_num>.{15})(?<calling_num>.{10})"
Local $sString = "#000#000#000031819 110100227 8*902 15709748756 77373 88888 0 0174 77373 0 0000215 #015" & @CRLF & _
"#000#000#000031819 11010007C 714012035854353 5010 0 54353 0 0000045 #015"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")